odhcp6c icon indicating copy to clipboard operation
odhcp6c copied to clipboard

Failed to send SOLICIT message to ff02::1:2 (Permission denied)

Open septem9er opened this issue 1 year ago • 0 comments

Hey, I do get the following error messages from odhcp:

odhcp6c[16857]: Failed to send RS (Permission denied)
odhcp6c[16857]: Failed to send SOLICIT message to ff02::1:2 (Permission denied)

I am using a turris omnia, my netconfig looks as follows:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd42:44d4:f241::/48'

config interface 'lan'
        option proto 'static'
        option ip6assign '64'
        option device 'br-lan'
        option _turris_mode 'managed'
        list ipaddr '192.168.178.1/24'

config interface 'wan'
        option ipaddr '192.168.8.10'
        option netmask '255.255.255.0'
        option gateway '192.168.8.1'
        option hostname 'turris'
        option proto 'pppoe'
        option device 'eth2.7'
        option keepalive '20 1'
        option username 'vodafone-vdsl.komplett/*redacted*-static'
        option password '*redacted*'
        option ipv6 '1'

config interface 'guest_turris'
        option enabled '1'
        option proto 'static'
        option ipaddr '10.111.222.1'
        option netmask '255.255.255.0'
        option device 'br-guest-turris'
        option ip6assign '64'

config interface 'wan6'
        option device '@wan'
        option reqprefix 'auto'
        option reqaddress 'try'
        option ip6gw '2a00:11:f982:2a00::1'
        option proto 'dhcpv6'

config device 'br_lan'
        option name 'br-lan'
        option bridge_empty '1'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option type 'bridge'

config device 'br_guest_turris'
        option bridge_empty '1'
        option type 'bridge'
        option name 'br-guest-turris'

config device 'dev_wan'
        option name 'eth2.7'

config route
        option gateway '192.168.178.42'
        option interface 'lan'
        option target '10.0.0.0'
        option netmask '255.0.0.0'

I did read somewhere, that ip -6 route add default dev pppoe-wan resolves the Permission denied error, which it does (not permanent that way). However, it still fails with (Address not available) afterwards.

I did see issue #55. My ISP does support IPv6 via dual stack for sure, but no link local address shows up with ifstatus wan:

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 25,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "eth2.7",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "176.95.*redacted*",
                        "mask": 32,
                        "ptpaddress": "84.58.120.1"
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "84.58.120.1",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [
                "176.95.16.250",
                "176.95.16.251"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

It does work with another router (a fritzBox).

Additional info:

ip -6 addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 state UP qlen 1024
    inet6 fe80::da58:d7ff:fe01:9486/64 scope link 
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1024
    inet6 fe80::da58:d7ff:fe01:9487/64 scope link tentative 
       valid_lft forever preferred_lft forever
14: br-guest-turris: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a00:11:f982:2aff::1/64 scope global deprecated dynamic 
       valid_lft 5133sec preferred_lft 0sec
    inet6 fd42:44d4:f241::1/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::c0f8:daff:fea5:34be/64 scope link 
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd42:44d4:f241:1::1/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::da58:d7ff:fe01:9486/64 scope link 
       valid_lft forever preferred_lft forever
22: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::6f0:21ff:fe45:e050/64 scope link 
       valid_lft forever preferred_lft forever
23: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::c2f8:daff:fea5:34be/64 scope link 
       valid_lft forever preferred_lft forever
24: guest_turris_1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::c0f8:daff:fea5:34be/64 scope link 
       valid_lft forever preferred_lft forever
25: guest_turris_0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::4f0:21ff:fe45:e050/64 scope link 
       valid_lft forever preferred_lft forever
854: eth2.7@eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::da58:d7ff:fe01:9487/64 scope link tentative 
       valid_lft forever preferred_lft forever

septem9er avatar Sep 08 '23 17:09 septem9er