easybox904 icon indicating copy to clipboard operation
easybox904 copied to clipboard

Simple guide doesn't work for 1und1

Open fpopic opened this issue 4 years ago • 12 comments

Hi @majuss,

Firstly thanks for the cool repository!

I tried to use the vodafone easybox 904 with opened firmware and followed all steps of your tutorial:

ssh -oKexAlgorithms=+diffie-hellman-group1-sha1 [email protected]
123456

# vdsl
ccfg_cli set username@wan050=1und1/[email protected]
ccfg_cli set password@wan050=XXXXXXXX
ccfg_cli set vlan_id@wan050=7

# adsl
ccfg_cli set username@wan000=1und1/[email protected]
ccfg_cli set password@wan000=XXXXXXXX

# activation
ccfg_cli set ivr_mode@bootstrap=2
ccfg_cli set arcor_pinConf@bootstrap=1
ccfg_cli set arcor_customer@bootstrap=1
ccfg_cli set keep_in_act@bootstrap=0   
ccfg_cli set FirstUseDate@tr69=2015-05-24T01:07:49

ccfg_cli commitcfg
reboot

image

image

Any clue what could it be?

Do I need to apply activation part every time changing something with ccfg_cli or only once?

fpopic avatar May 16 '20 22:05 fpopic

Everytime you change something you need to run: ccfg_cli commitcfg. For me it looks fine, what exactly is not working?

Please never use sudo with ssh.

majuss avatar May 18 '20 09:05 majuss

For me it looks fine, what exactly is not working?

As you can see on the picture there is no data connection. Is there a way I can provide you with more details? You are using it on 1und1 or?

fpopic avatar May 18 '20 11:05 fpopic

I used it on a Telekom line. Actually I don't see where it says that it failed somewhere. "Show Time" means that is successfully connected. Look at closed issues for further details on 1&1 or use openwrt.

majuss avatar May 18 '20 11:05 majuss

Yeah it is somehow weird

image

I didn't even put anything about VOIP or Telephone connection and this one is green and data is red (and internet doesn't work).

Will try to get some error code. Thanks!

fpopic avatar May 18 '20 11:05 fpopic

@fpopic I've had the same problem, i fixed it by doing this after applying the information and rebooting.

cd .. cd /etc/ppp ./ip-down ./ip-up

(with the ip-up script you need to wait for probably 20 seconds and then do ctrl+c) after that reboot, then telephony and DSL should connect successfully.

If it still doesn't connect then try also doing this:

ccfg_cli set mtu@wan000=1500 and ccfg_cli set mtu@wan050=1500

I hope i helped anyone.

Wapitiii avatar Aug 18 '21 17:08 Wapitiii

@Wapitiii

did it work for you on 1und1 or on Telekom?

I tried all you wrote and still it doesn't work for 1und1.

here is my log:

root@easy:~# cat /tmp/etc/config/network
# package "network"

config switch eth0
	option vlan71	"4t 6*"
	option vlan66	"0 1 2 3 6*"
	option vlan66	"4t 6*"

config interface loopback
	option ifname "lo"
	option proto "static"
	option ipaddr "127.0.0.1"
	option netmask "255.0.0.0"

config interface lan
	option up "1"
	option ifname "eth0.66"
	option type "bridge"
	option proto "static"
	option ipaddr "192.168.2.1"
	option netmask "255.255.255.0"
	option macaddr "18:83:BF:1E:CA:5C"

config alias
	option interface "lan"
	option proto "static"
	option ipaddr "0.0.0.0"
	option netmask "0.0.0.0"

config interface lan1
	option up "1"
	option ifname "eth0.71"
	option type "bridge"
	option proto "static"
	option ipaddr "192.168.3.1"
	option netmask "255.255.255.0"
	option macaddr "18:83:BF:1E:CA:5D"

config interface lan2
	option up "0"
	option ifname "eth0.3"
	option type "bridge"
	option proto "disable"
	option ipaddr "192.168.4.1"
	option netmask "255.255.255.0"
	option macaddr "18:83:BF:1E:CA:5E"

config interface lan3
	option up "0"
	option ifname "eth0.4"
	option type "bridge"
	option proto "disable"
	option ipaddr "192.168.5.1"
	option netmask "255.255.255.0"
	option macaddr "18:83:BF:1E:CA:5F"


config interface wan050
	option up	"1"
	option ifname	"ptm0.7"
	option proto	"pppoe"
	option ipaddr	"0.0.0.0"
	option netmask	"0.0.0.0"
	option gateway	"0.0.0.0"
	option username	"1und1/[email protected]"
	option password	"XXXXX"
	option defaultroute	"1"
	option keepalive	"3,15"
	option mtu	"1500"
	option disconnecttype	"1"
	option disconnecttime	"02-05"
	option clientid	""

config interface wan051
	option up	"0"
	option proto	"disable"

config interface wan052
	option up	"0"
	option proto	"disable"

config atm-bridge000
	option unit	"0"
	option encaps	"llc"
	option vpi	"1"
	option vci	"32"
	option payload	"bridged"

config interface wan000
	option encaps	"llc"
	option vpi	"1"
	option vci	"32"

config atm-bridge001
	option unit	"1"
	option encaps	"llc"
	option vpi	"2"
	option vci	"32"
	option payload	"bridged"

config interface wan001
	option encaps	"llc"
	option vpi	"2"
	option vci	"32"

config atm-bridge002
	option unit	"2"
	option encaps	"llc"
	option vpi	"3"
	option vci	"32"
	option payload	"bridged"

config interface wan002
	option encaps	"llc"
	option vpi	"3"
	option vci	"32"

config interface wan303
	option up	"1"
	option ifname	"lte3"
	option proto	"dhcp"
	option macaddr	"18:83:BF:1E:CA:61"
	option defaultroute	"1"
	option keepalive	"3,15"
	option mtu	"1364"
	option clientid	""

1und1-easybox 1und1-easybox2

fpopic avatar Dec 03 '22 20:12 fpopic

I would try openWrt. Quite funny: Login failed, Login success, modem hangup :D

majuss avatar Dec 03 '22 20:12 majuss

Do you know what might be missing compared to O2 use case from @xxww1 xxww1 that worked

https://github.com/majuss/easybox904/issues/38#issuecomment-479827663

here is the log of all @wan050 values from @xxww1 02 setup without ipv6 things

...
netsection@wan050 = wan050
adminstate@wan050 = disable
ifname@wan050 = ptm0.132
proto@wan050 = pppoe
ip4addr@wan050 = 0.0.0.0
ip4mask@wan050 = 0.0.0.0
ip4gateway@wan050 = 0.0.0.0
username@wan050 = USERNAME
password@wan050 = PASSWORD
on-demand@wan050 = 0
idletime@wan050 = 10
auto_reconnect@wan050 = 1
auto_reconnect_start@wan050 = 120
auto_reconnect_interval@wan050 = 180
ppp_startup@wan050 = 1
ppp_laststate@wan050 = 0
lcp_echo_interval@wan050 = 15
lcp_echo_fail@wan050 = 3
macaddr@wan050 =
mtu@wan050 = 1492
disconnecttype@wan050 = 1
disconnecttime@wan050 = 02-05
defaultroute@wan050 = 1
vlan_tagged@wan050 = 1
vlan_id@wan050 = 7
.... 

fpopic avatar Dec 03 '22 20:12 fpopic

I don't think anybody got it working with O2.

Use openWrt: https://github.com/zuzia-dev/Easybox-904xDSL-repo-source/

majuss avatar Dec 03 '22 21:12 majuss

I tried openwrt, but I never got working to have vdsl/adsl with openwrt. Guess this development is more for wifi/3g.

Regarding

I would try openWrt. Quite funny: Login failed, Login success, modem hangup :D

Login failed, login success was bad on my side at the password attempt to enter auth when accessing 192.168.2.1 :-)

Regarding modem hangup, would like to debug what really happens but have not that strong knowledge.

fpopic avatar Dec 03 '22 21:12 fpopic

@majuss do you know what is

mtu@wan050 = 1492

and what is 1500 vs 1492 for?

fpopic avatar Dec 03 '22 21:12 fpopic

It's a packetsize. https://www.cloudflare.com/de-de/learning/network-layer/what-is-mtu/ In general, if you're setting it to a lower value like 1280 things have a higher possibility to work.

majuss avatar Dec 09 '22 12:12 majuss