pineapple-firmware-builder icon indicating copy to clipboard operation
pineapple-firmware-builder copied to clipboard

pineapd not starting

Open bruvv opened this issue 5 years ago • 56 comments

PineAPD not starting This is a known issue that I cannot fix at this point. The error is as follows:

do_page_fault(): sending SIGSEGV to pineapd for invalid read access from 0000005c
[ 515.263461] epc = 770088a1 in libpcap.so.1[77000000+2b000]
[ 515.268826] ra = 004053f8 in pineapd[400000+e000]

The pineapd.bin is a 32 BIT ELF program. that is somewhat obfuscated. You can read the strings but it does not show anything really. I have no idea how objdump works but is supposed to show what is going on. What I have tried via trail and error:

  • Change mips name (works for everything expect the pineapd)
  • Change the board name from GL-AR150 to PINEAPPLE-NANO, or I am doing this wrong but the GL-AR150 does not boot.
  • Change the build to a specifiek TP-LINK board (just like the pineapple NANO does with 5 MTD partitions) but that also makes the GL-AR150 crash...
  • Changes some specifiek offsets in the MIPS/MACH file but that makes no difference.
  • Updated the packages to mimick the PINEAPPLE NANO AIRCRACK HAK5 package which is called by pineapd but that is still giving the segment fault...
  • updated the kernel to the new build that HAK5 is using it boots but still pineapd does not work

Without any succes

pineap.bin can be downloaded here: https://github.com/d1slact0r/pineapple-firmware-builder/blob/master/pineap

bruvv avatar Oct 17 '18 09:10 bruvv

Are you still testing this? I have a patched binary that I would like to try but I do not have a GL-AR150 to test with.

cjensenius avatar Jan 31 '19 13:01 cjensenius

Mine is broken at the moment. I messed up my uboot so I can not test it. But if you want you can share it and I can post it.

bruvv avatar Jan 31 '19 14:01 bruvv

Hi guys, I've been following this for some time. The last version that is working for me so far is the 2.0.2. I still have a working GL-AR150 at hand, I can test things for you.

codexv avatar Feb 02 '19 08:02 codexv

https://github.com/blu3b0x/pineapple-firmware-builder/tree/master/firmware_images has just added a confirmed GL-AR300M build and a test AR150 build for 2.4.2, use at your own risk

blu3b0x avatar Feb 03 '19 02:02 blu3b0x

Tried the 2.4.2 for AR150. Looks like it's all working except for the Internet connection sharing through ethernet cable. I can't make it work with this build.

Edit: I was having problems with connecting it to another router (through ethernet cable) to get internet access but I happen to make it work by editing the /etc/config/network and adding the following:

config interface 'wan'        option ifname 'eth1'        option proto 'dhcp'

It is now possible to connect it using the "LAN" port.

codexv avatar Feb 05 '19 04:02 codexv

thanks for the edit, i will try to make my AR150 working hopefully and will try and update more.

bruvv avatar Feb 06 '19 10:02 bruvv

PineAP in bluebox's 2.4.2 test build works! What did you do to fix it?

Cheers

PaulMoore2018 avatar Feb 22 '19 23:02 PaulMoore2018

https://github.com/blu3b0x/pineapple-firmware-builder/commit/07b15a0cb3ea518bb5dc8e6260307f8b581e76eb

Just enabled the correct kernel options

blu3b0x avatar Feb 23 '19 01:02 blu3b0x

forgot to close this

bruvv avatar Feb 24 '19 09:02 bruvv

broken again in 2.5.x

xchwarze avatar Apr 01 '19 01:04 xchwarze

@xchwarze what is the error?

bruvv avatar Apr 06 '19 20:04 bruvv

@d1slact0r @blu3b0x since version 2.5.0 PineAP crash with "Segmentation fault"

xchwarze avatar Apr 06 '19 21:04 xchwarze

@xchwarze I can not test it since my ar150 is still dead... can you open a new issue with some log files? Please run pineapd with --debub flag to know what is going on

bruvv avatar Apr 07 '19 08:04 bruvv

@d1slact0r root@Pineapple:/sd/test# ./pineapd --debug Segmentation fault

xchwarze avatar Apr 09 '19 02:04 xchwarze

I am getting the same issue with 2.5.x nothing in dmesg

Bl4d3666 avatar Apr 27 '19 04:04 Bl4d3666

here is the settings for me so the the Ethernet WAN port and LAN port is able to work as intended:

in lan change eth0 to eth1:

config interface 'lan'
	option ifname 'eth1'

in wwan add eth0:

config interface 'wwan'
	option ifname 'eth0'

joebertj avatar May 11 '19 01:05 joebertj

pineapd although running is still not working since it is missing pinesniffer:

# site_survey 30
sh: pinesniffer: not found

joebertj avatar May 11 '19 01:05 joebertj

@joebertj https://forums.hak5.org/topic/44334-daemon-wont-enable/?do=findComment&comment=311210 more info here about the pinesniffer not found ;)

Also where did you change those eth0 and eth1?

bruvv avatar May 11 '19 18:05 bruvv

Look like they have add protection http://gerryk.com/posts/using_ghidra_to_reverse_wifi_pineapple_protection/

Bl4d3666 avatar May 18 '19 11:05 Bl4d3666

Already tried tinkering with the proc files. Didn't do much so do not think that's the trick.

bruvv avatar May 18 '19 17:05 bruvv

Already tried tinkering with the proc files. Didn't do much so do not think that's the trick.

after 2.5.x version?

The pineap in 2.5.x branch is a rewriten version

xchwarze avatar May 18 '19 18:05 xchwarze

At this stage my pineapple broke after I uploaded the latest working version (was messing with a custom uboot and fried a chip never got a new chip to work) so no I did not have a working pineapple to test anything new :(

bruvv avatar May 18 '19 18:05 bruvv

maybe changing

  1. board name from GL-AR150 to PINEAPPLE-NANO
  2. change string 44b65156 to 3291d874 in pineapd

maybe this works...

xchwarze avatar May 18 '19 20:05 xchwarze

Like I said. Just change the board name in the build like here: https://github.com/bruvv/pineapple-firmware-builder/commit/ae9d3476cc33cb25695989bc7d54dcbd31ccc90a Try that commit with the new build perhaps it works now.

bruvv avatar May 18 '19 20:05 bruvv

pineap 2.5.4 cracked https://multifilemirror.com/iyqiujac29e9 https://mirrorace.com/m/1y27l https://multiup.org/download/ae195637d92aa9d3a6622405a9463951/pineap-254-crack.zip

xchwarze avatar May 19 '19 20:05 xchwarze

Source ?

bruvv avatar May 19 '19 20:05 bruvv

I crack it last night

xchwarze avatar May 19 '19 20:05 xchwarze

Like I said. Source ;)? So we now it is save to use. How did you do it ?

bruvv avatar May 19 '19 20:05 bruvv

patching gtmgc() and getbrd() for read fake data in crack.1 and crack.2 files

xchwarze avatar May 19 '19 20:05 xchwarze

can you make a detailed tutorial so we all can enjoy it even after this level :) ?

bruvv avatar May 21 '19 17:05 bruvv

Also where did you change those eth0 and eth1?

/etc/config/network

lan is assumed to be eth0 by pineapple but then it is the wan. eth1 is lan. i can then attach another usb wireless adapter seen here as usb0.

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '172.16.42.1'
	option gateway '172.16.42.42'
	option dns '8.8.8.8, 8.8.4.4'

config interface 'usb'
	option ifname 'usb0'
	option proto 'dhcp'
	option dns '8.8.8.8, 8.8.4.4'

config interface 'wwan'
	option proto 'dhcp'
	option dns '8.8.8.8, 8.8.4.4'

I also tinkered with my /etc/config/wireless.

radio0 is the built-in radio. i made it as client ap ("sta"). my extra radio1 as ap. the ordering is to match the parsing of the gui interface, here offlimits is management.

FreeWIFI here is passwordless but you need to remove option encryption and put option key 'somepassword" to work. myhome is my home wifi.

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ar933x_wmac'
	option htmode 'HT20'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ehci-platform/usb1/1-1/1-1.4/1-1.4:1.0'
	option htmode 'HT20'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'FreeWIFI'
	option key 'doesnotmatter'
	option maxassoc '100'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'offlimits'
	option key 'aptoconnecttomanagepineapple'
	option hidden '1'

config wifi-iface
	option device 'radio0'
	option network 'wwan'
	option mode 'sta'
	option encryption 'psk2'
	option ssid 'myhome'
	option key 'homeaptoshareinternet'
	option disabled '0'

since i can manipulate this two files, when on the road i use radio0 to connect to my phone personal hotspot.

and since the space is limited. i have a usb hub where i connect the extra wireless adapater and a flash drive and use it as the overlayfs.

joebertj avatar May 26 '19 21:05 joebertj

So, where are we finally? is this builder already updated with patched pineapd? or do I have to manually repack the files once the firmware is updated?

mankidavu avatar Jun 12 '19 13:06 mankidavu

aslong as there is no open source explaination by @xchwarze i will not publish it here ;)

bruvv avatar Jun 12 '19 13:06 bruvv

aslong as there is no open source explaination by @xchwarze i will not publish it here ;)

the explanation is in this thread. anyway you can make a patch diffing ELF files

So, where are we finally? is this builder already updated with patched pineapd? or do I have to manually repack the files once the firmware is updated?

I create a firmware using a new technique that I'm experimenting with. Flash this fw https://github.com/xchwarze/AR150-WiFiPineapple-2019

xchwarze avatar Jun 12 '19 18:06 xchwarze

OK, so I just got mine GL-AR150 and ended up here. Patching /usr/sbin/pineapd is quite simple. I've kept it to bare (and non-pretty) minimum, by replacing string dmesg with Dmesg and /proc/cmdline with /bin/.cmdline. All in all, 6 bytes changed. After that, I've created file /bin/.cmdline with

board=PINEAPPLE-NANO console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd

and executable file /bin/Dmesg with

echo -e '[\t0.000000] Linux version 3.18.23 (sebkinne@Worker) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46591) ) #13 Thu Jan 21 13:34:28 PST 2016
[\t0.000000] MyLoader: sysp=8a14b024, boardp=44b65156, parts=b69f8d32
[\t0.000000] bootconsole [early0] enabled'
exit 0

And it works, as far as starting "PineAP Daemon" goes. I'm new to Pineapple WiFi, so not sure what to check next.

Here's brief summary of all commands I've used to build my firmware. If you don't trust my binary patch you can change those 6 characters yourself.

mkdir gl-inet && cd gl-inet
git clone https://github.com/gl-inet/imagebuilder-cc-ar71xx.git
wget https://www.wifipineapple.com/downloads/nano/latest
binwalk -e latest && rm latest
mkdir imagebuilder-cc-ar71xx/files
cp -a _latest.extracted/squashfs-root/* imagebuilder-cc-ar71xx/files/

echo 'IyEvYmluL2Jhc2gKZWNobyAtZSAnW1x0MC4wMDAwMDBdIExpbnV4IHZlcnNpb24gMy4xOC4yMyAo
c2Via2lubmVAV29ya2VyKSAoZ2NjIHZlcnNpb24gNC44LjMgKE9wZW5XcnQvTGluYXJvIEdDQyA0
LjgtMjAxNC4wNCByNDY1OTEpICkgIzEzIFRodSBKYW4gMjEgMTM6MzQ6MjggUFNUIDIwMTYKW1x0
MC4wMDAwMDBdIE15TG9hZGVyOiBzeXNwPThhMTRiMDI0LCBib2FyZHA9NDRiNjUxNTYsIHBhcnRz
PWI2OWY4ZDMy77u/CltcdDAuMDAwMDAwXSBib290Y29uc29sZSBbZWFybHkwXSBlbmFibGVkJwpl
eGl0IDAK' | base64 -d > imagebuilder-cc-ar71xx/files/bin/Dmesg
chmod 755 imagebuilder-cc-ar71xx/files/bin/Dmesg

echo 'IGJvYXJkPVBJTkVBUFBMRS1OQU5PIGNvbnNvbGU9dHR5QVRIMCwxMTUyMDAgcm9vdGZzdHlwZT1z
cXVhc2hmcyxqZmZzMiBub2luaXRyZAo=' | base64 -d > imagebuilder-cc-ar71xx/files/bin/.cmdline
chmod 444 imagebuilder-cc-ar71xx/files/bin/.cmdline

echo 'QlNESUZGNDA4AAAAAAAAAEUAAAAAAAAAQCMCAAAAAABCWmg5MUFZJlNZGW3hLQAABtzAcCAIAAgA
QABAAEAAIAAiNAbUIMmId0lsvgPF3JFOFCQGW3hLQEJaaDkxQVkmU1n29nfYAAETUGXAAAABAgAA
AIAEQAAQiKAAMQAwClUPU0yc5BX3VBNYKos91vCIb5+LuSKcKEh7ezvsAEJaaDkXckU4UJAAAAAA' | base64 -d > patch
mv imagebuilder-cc-ar71xx/files/usr/sbin/pineapd imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
bspatch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig imagebuilder-cc-ar71xx/files/usr/sbin/pineapd patch && rm patch
chmod 755 imagebuilder-cc-ar71xx/files/usr/sbin/pineapd

echo 'CONFIG_POSIX_MQUEUE=y' >> ./imagebuilder-cc-ar71xx/target/linux/ar71xx/config-3.18
echo 'CONFIG_POSIX_MQUEUE_SYSCTL=y' >> ./imagebuilder-cc-ar71xx/target/linux/ar71xx/config-3.18

cd imagebuilder-cc-ar71xx
make -j8 image PROFILE=GL-AR150 PACKAGES="kmod-ath9k-htc kmod-rtlwifi-usb" FILES=files/

manwe-pl avatar Jul 09 '19 18:07 manwe-pl

Good work @manwe-pl. Will test it during this weekend

mankidavu avatar Jul 09 '19 19:07 mankidavu

Those paths could and should be changed to something nicer. Dmesg and /bin/.cmdline were just quick and dirty tests.

After some toying around I found it probably doesn't work as it should. For example nothing is returned in "recon" scan. Also there's another file that needs patching - /usr/bin/pineap. I'll get back to it tomorrow.

manwe-pl avatar Jul 09 '19 20:07 manwe-pl

New version. This time I've changed names to something nicer. Fake dmesg becomes crack and fake /proc/cmdline is placed in /etc/crackcmd. You can use my binary patches or change those paths in /usr/sbin/pineapd and /usr/bin/pineap yourself.

echo 'IyEvYmluL2Jhc2gKZWNobyAtZSAnW1x0MC4wMDAwMDBdIExpbnV4IHZlcnNpb24gMy4xOC4yMyAo
c2Via2lubmVAV29ya2VyKSAoZ2NjIHZlcnNpb24gNC44LjMgKE9wZW5XcnQvTGluYXJvIEdDQyA0
LjgtMjAxNC4wNCByNDY1OTEpICkgIzEzIFRodSBKYW4gMjEgMTM6MzQ6MjggUFNUIDIwMTYKW1x0
MC4wMDAwMDBdIE15TG9hZGVyOiBzeXNwPThhMTRiMDI0LCBib2FyZHA9NDRiNjUxNTYsIHBhcnRz
PWI2OWY4ZDMy77u/CltcdDAuMDAwMDAwXSBib290Y29uc29sZSBbZWFybHkwXSBlbmFibGVkJwpl
eGl0IDAK' | base64 -d > imagebuilder-cc-ar71xx/files/bin/crack
chmod 755 imagebuilder-cc-ar71xx/files/bin/crack

echo 'IGJvYXJkPVBJTkVBUFBMRS1OQU5PIGNvbnNvbGU9dHR5QVRIMCwxMTUyMDAgcm9vdGZzdHlwZT1z
cXVhc2hmcyxqZmZzMiBub2luaXRyZAo=' | base64 -d > imagebuilder-cc-ar71xx/files/etc/cmdcrack
chmod 444 imagebuilder-cc-ar71xx/files/etc/cmdcrack

echo 'QlNESUZGNDA2AAAAAAAAAFQAAAAAAAAAQCMCAAAAAABCWmg5MUFZJlNZCn/1RwAABtTAcCAIAMAA
QABAACAAIjQG1CDJiHdJbL4DxdyRThQkAp/9UcBCWmg5MUFZJlNZxF82lQABE1hk1xAAgAQAAgAA
CAAERsygAFCmTEyDIwRUj1ANM1PUiUAWLKAJ3CIqDj2tLXjFjNXmpzwCCBP1fi7kinChIYi+bSpC
Wmg5F3JFOFCQAAAAAA==' | base64 -d > patch
mv imagebuilder-cc-ar71xx/files/usr/sbin/pineapd imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
bspatch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig imagebuilder-cc-ar71xx/files/usr/sbin/pineapd patch && rm patch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
chmod 755 imagebuilder-cc-ar71xx/files/usr/sbin/pineapd

echo 'QlNESUZGNDA0AAAAAAAAAFIAAAAAAAAAeIcAAAAAAABCWmg5MUFZJlNZSSDKnwAABnDAYBAAIAAA
gEBAgCAAMQwIEoMmmzAG508XckU4UJBJIMqfQlpoOTFBWSZTWWFswAkAAETchNcQAIAEAAQAAIAA
BEbMoABUUyYmQZGCKkeoBpmp6kSIMWRE6gVQce1pa8YsZq81OeFQD35oXckU4UJBhbMAJEJaaDkX
ckU4UJAAAAAA' | base64 -d > patch
mv imagebuilder-cc-ar71xx/files/usr/bin/pineap imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig
bspatch imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig imagebuilder-cc-ar71xx/files/usr/bin/pineap patch && rm patch imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig
chmod 755 imagebuilder-cc-ar71xx/files/usr/bin/pineap

And now it works :) 1

manwe-pl avatar Jul 10 '19 16:07 manwe-pl

. . . And now it works :) 1

I've successful built with your lines but pineap daemon doesn't work. It could be my wifi usb ? Should I use RT5370 ?

  • TL-WN722N (AR9721) > recognised, but pineap didn't work
  • AWUS036NHA (AR9271) > recognised, but pineap didn't work
  • AWUS036NEH (RT3070) > not recognised

ghost avatar Jul 11 '19 16:07 ghost

I'm using AR9271 dongle and it works. Try starting pineapd manually (/usr/sbin/pineapd /tmp/pine*conf) and see what's going on.

manwe-pl avatar Jul 11 '19 16:07 manwe-pl

ezezeze

cat /bin/crack

nvbnvng

terminal

   25  git clone https://github.com/gl-inet/imagebuilder-cc-ar71xx.git
   26  wget https://www.wifipineapple.com/downloads/nano/latest
   32  apt update
   33  apt install binwalk
   34  binwalk -e latest && rm latest
   35  mkdir imagebuilder-cc-ar71xx/files
   36  cp -a _latest.extracted/squashfs-root/* imagebuilder-cc-ar71xx/files/
   37  echo 'c2Via2lubmVAV29ya2VyKSAoZ2NjIHZlcnNpb24gNC44LjMgKE9wZW5XcnQvTGluYXJvIEdDQyA0
LjgtMjAxNC4wNCByNDY1OTEpICkgIzEzIFRodSBKYW4gMjEgMTM6MzQ6MjggUFNUIDIwMTYKW1x0
MC4wMDAwMDBdIE15TG9hZGVyOiBzeXNwPThhMTRiMDI0LCBib2FyZHA9NDRiNjUxNTYsIHBhcnRz
PWI2OWY4ZDMy77u/CltcdDAuMDAwMDAwXSBib290Y29uc29sZSBbZWFybHkwXSBlbmFibGVkJwpl
eGl0IDAK' | base64 -d > imagebuilder-cc-ar71xx/files/bin/crack
   38  chmod 755 imagebuilder-cc-ar71xx/files/bin/crack
   39  echo 'IGJvYXJkPVBJTkVBUFBMRS1OQU5PIGNvbnNvbGU9dHR5QVRIMCwxMTUyMDAgcm9vdGZzdHlwZT1z
cXVhc2hmcyxqZmZzMiBub2luaXRyZAo=' | base64 -d > imagebuilder-cc-ar71xx/files/etc/cmdcrack
   40  chmod 444 imagebuilder-cc-ar71xx/files/etc/cmdcrack
   41  echo 'QlNESUZGNDA2AAAAAAAAAFQAAAAAAAAAQCMCAAAAAABCWmg5MUFZJlNZCn/1RwAABtTAcCAIAMAA
QABAACAAIjQG1CDJiHdJbL4DxdyRThQkAp/9UcBCWmg5MUFZJlNZxF82lQABE1hk1xAAgAQAAgAA
CAAERsygAFCmTEyDIwRUj1ANM1PUiUAWLKAJ3CIqDj2tLXjFjNXmpzwCCBP1fi7kinChIYi+bSpC
Wmg5F3JFOFCQAAAAAA==' | base64 -d > patch
   42  mv imagebuilder-cc-ar71xx/files/usr/sbin/pineapd imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
   43  bspatch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig imagebuilder-cc-ar71xx/files/usr/sbin/pineapd patch && rm patch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
   44  apt-get install bspatch
   45  bspatch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig imagebuilder-cc-ar71xx/files/usr/sbin/pineapd patch && rm patch imagebuilder-cc-ar71xx/files/usr/sbin/pineapd.orig
   46  chmod 755 imagebuilder-cc-ar71xx/files/usr/sbin/pineapd
   47  echo 'QlNESUZGNDA0AAAAAAAAAFIAAAAAAAAAeIcAAAAAAABCWmg5MUFZJlNZSSDKnwAABnDAYBAAIAAA
gEBAgCAAMQwIEoMmmzAG508XckU4UJBJIMqfQlpoOTFBWSZTWWFswAkAAETchNcQAIAEAAQAAIAA
BEbMoABUUyYmQZGCKkeoBpmp6kSIMWRE6gVQce1pa8YsZq81OeFQD35oXckU4UJBhbMAJEJaaDkX
ckU4UJAAAAAA' | base64 -d > patch
   48  mv imagebuilder-cc-ar71xx/files/usr/bin/pineap imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig
   49  bspatch imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig imagebuilder-cc-ar71xx/files/usr/bin/pineap patch && rm patch imagebuilder-cc-ar71xx/files/usr/bin/pineap.orig
   50  chmod 755 imagebuilder-cc-ar71xx/files/usr/bin/pineap
   51  echo 'CONFIG_POSIX_MQUEUE=y' >> ./imagebuilder-cc-ar71xx/target/linux/ar71xx/config-3.18
   52  echo 'CONFIG_POSIX_MQUEUE_SYSCTL=y' >> ./imagebuilder-cc-ar71xx/target/linux/ar71xx/config-3.18
   53  cd imagebuilder-cc-ar71xx
   54  make -j8 image PROFILE=GL-AR150 PACKAGES="kmod-ath9k-htc kmod-rtlwifi-usb" FILES=files/

ghost avatar Jul 11 '19 16:07 ghost

Oh, how nice, I've skipped first line of base64 for /bin/crack.

Should be:

echo 'IyEvYmluL2Jhc2gKZWNobyAtZSAnW1x0MC4wMDAwMDBdIExpbnV4IHZlcnNpb24gMy4xOC4yMyAo
c2Via2lubmVAV29ya2VyKSAoZ2NjIHZlcnNpb24gNC44LjMgKE9wZW5XcnQvTGluYXJvIEdDQyA0
LjgtMjAxNC4wNCByNDY1OTEpICkgIzEzIFRodSBKYW4gMjEgMTM6MzQ6MjggUFNUIDIwMTYKW1x0
MC4wMDAwMDBdIE15TG9hZGVyOiBzeXNwPThhMTRiMDI0LCBib2FyZHA9NDRiNjUxNTYsIHBhcnRz
PWI2OWY4ZDMy77u/CltcdDAuMDAwMDAwXSBib290Y29uc29sZSBbZWFybHkwXSBlbmFibGVkJwpl
eGl0IDAK' | base64 -d > imagebuilder-cc-ar71xx/files/bin/crack
chmod 755 imagebuilder-cc-ar71xx/files/bin/crack

I'll correct post above.

manwe-pl avatar Jul 11 '19 17:07 manwe-pl

I've been playing with GL-AR150 today. Here are some useful modifications.

This one fixes swaped LAN/WAN ports:

echo 'IyEvYmluL3NoCgpbIC1lIC9ldGMvY29uZmlnL25ldHdvcmsgXSAmJiBleGl0IDAKCnRvdWNoIC9l
dGMvY29uZmlnL25ldHdvcmsKCi4gL2xpYi9mdW5jdGlvbnMvdWNpLWRlZmF1bHRzLnNoCi4gL2xp
Yi9hcjcxeHguc2gKCnVjaWRlZl9zZXRfaW50ZXJmYWNlX2xvb3BiYWNrCnVjaWRlZl9zZXRfaW50
ZXJmYWNlc19sYW5fd2FuICJldGgxIiAiZXRoMCIKdWNpIGNvbW1pdCBuZXR3b3JrCmV4aXQgMAo=' | base64 -d > imagebuilder-cc-ar71xx/files/etc/uci-defaults/02_network

Device detection. Two scripts have TETRA because we have WAN port to play with.

sed -i 's/..Get Version and Device/device="TETRA"/' imagebuilder-cc-ar71xx/files/etc/uci-defaults/90-firewall.sh
sed -i 's/..Get Version and Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/uci-defaults/91-fstab.sh
sed -i 's/..Get Version and Device/device="TETRA"/' imagebuilder-cc-ar71xx/files/etc/uci-defaults/95-network.sh
sed -i 's/..Get Version and Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/uci-defaults/97-pineapple.sh
sed -i 's/..Get Version and Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/hotplug.d/usb/30-sd
sed -i 's/..Get Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/rc.button/BTN_1
sed -i 's/..Get Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/rc.button/reset
sed -i 's/..Get Device/device="NANO"/' imagebuilder-cc-ar71xx/files/etc/rc.local
sed -i 's/exit 0/true/' imagebuilder-cc-ar71xx/files/etc/hotplug.d/block/20-sd

This one allows to get news, modules list, etc.

sed -i 's/unknown/nano/' imagebuilder-cc-ar71xx/files/pineapple/api/pineapple.php

USB pendrive support. You have to change 1567:8902 according to you vendor/product ID, and add kmod-fs-XXX kmod-usb-storage to PACKAGES=""

sed -i 's/05e3/1567/' imagebuilder-cc-ar71xx/files/etc/hotplug.d/block/20-sd
sed -i 's/0745/8902/' imagebuilder-cc-ar71xx/files/etc/hotplug.d/block/20-sd
sed -i 's/5e3.745.933/1567\/8902\/100/' imagebuilder-cc-ar71xx/files/etc/hotplug.d/usb/30-sd
sed -i 's/0745/8902/' imagebuilder-cc-ar71xx/files/etc/rc.button/BTN_1

That's it for now. So far I have working USB memory (/sd storage and swap), working news, and modules are installing fine.

manwe-pl avatar Jul 13 '19 23:07 manwe-pl

USB pendrive support didn't work for me Which filesystem did you choose ? ext4 ? with kmod-fs-ext4 ?

Edit : I've found the solution

add to PACKAGES=""

kmod-lib-crc32c kmod-crypto-crc32c

from de GUI Advanced tabs edit the fstab

config mount
	option	target		'/sd'
	option	device		'/dev/sda1'
	option	fstype		'ext4'
	option	options		'rw,sync'
	option	enabled		'1'

ghost avatar Jul 18 '19 17:07 ghost

I'm using xfs which, apparently, didn't need crc32c. As for the config mount, changing device to /dev/sda1 is not needed if you add vendor/productID into /etc/hotplug.d/block/20-sd and 30-sd. Those scripts take care of creating necessary symlinks. But we are digressing from this ticket's topic.

manwe-pl avatar Jul 18 '19 19:07 manwe-pl

@489269 merged per your request. and read the wiki ;) https://github.com/bruvv/pineapple-firmware-builder/wiki/USB-Storage-(FSTAB)

@manwe-pl thank you so much for your work! if only my pineapple would still be alive :( still have to fix the uboot...

bruvv avatar Aug 10 '19 18:08 bruvv

Great to see some momentum here. :) I am planning to step up to an ar -300, as ar150 is having so low storage options (unless you mount a USB permanently and extend the space).

mankidavu avatar Aug 25 '19 17:08 mankidavu

Hi everyone i have 6416a uploaded cracked firmware but i can't find wlan1 and pineapd doesn't work i want crack for 6416a please ask

lipomos avatar Aug 27 '19 07:08 lipomos

pineap 2.7.0 cracked https://bbs.ichunqiu.com/thread-57900-1-1.html

BH2UOL avatar Jul 19 '20 13:07 BH2UOL

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

bruvv avatar Jul 20 '20 12:07 bruvv

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

BH2UOL avatar Jul 20 '20 13:07 BH2UOL

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

Do not need to speak english, if you can find a way to contribute in any other way that will be also highly appreciated :)

bruvv avatar Jul 20 '20 13:07 bruvv

Have you fix the sd card not found on pisen wmm003n?> > thanks @A2gel made a writeup in english here:

https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD

Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

4dvn avatar Apr 02 '21 06:04 4dvn

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

729ED780-F38F-49B1-B9EB-7F6B1F5A8A41 Fixed on pisen cloud router sd card

4dvn avatar Apr 06 '21 08:04 4dvn

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

729ED780-F38F-49B1-B9EB-7F6B1F5A8A41 Fixed on pisen cloud router sd card

I haven't fixed the problem that SD card hasn't found. I can try it in the near future

BH2UOL avatar Apr 06 '21 08:04 BH2UOL

thanks @A2gel made a writeup in english here: https://github.com/bruvv/pineapple-firmware-builder/blob/master/crack_pineapd.MD Please feel free to contribute

😂 My english is not good, so i can't writeup english version. Thanks for your translation

729ED780-F38F-49B1-B9EB-7F6B1F5A8A41 Fixed on pisen cloud router sd card

I haven't fixed the problem that SD card hasn't found. I can try it in the near future

39706941-3B37-4C66-8705-B3184B484075 Plugin your cable like this 😂, do you have whatsapp i need contact you: +84903408066

4dvn avatar Apr 06 '21 08:04 4dvn